Google Drive inside Schoology has changed
Resolved
UPDATED on 4-15-24

When you opened the previous version of the Google Drive Resource app, you could access all of your Google Drive content directly in the app. The new changes have you go through another step by selecting the Google Drive content that you want to access in Schoology. The rest of the workflow is the same.

Post our release on 4th April, on opening the Google Drive Resource App, you may have noticed an additional option under "Add Resources", that says "Add files from Google Drive".

When you click "Add files from Google Drive", a new pop-up will ask you to select files to share with Schoology. With the new file picker, you will be able to search, filter and sort the files

Notes:
You will not be able to select or add folders to the application and can only select specific files from the list.

After you have selected the files from the dialog box, click on "Select", and it will include those files and return to Schoology. Any document that was already added to materials or shared to a course will not be impacted by this; however, users will need to reselect materials for any new work.

Additional Changes (released on April 19, 2024):

There is no longer a separation of files that display in the app. The "My Drive" and "Shared with Me" options have been removed based on changes from Google's API. Instead of having to click on "Shared with Me" to see the files that you have added that have come from another user, you will see a list of all the files together on the main app page.

This API change does allow shared drive files to be added to Schoology using the Google Drive Resource App now. So when you click Add files from Google Drive, you will see all the files you have available to you in your Google Drive including your files, user files shared with you, and district shared drive files shared with you.

Previously, if you tried to add a file that was shared from a shared drive, there was no place in the app to display it because the display was limited to "My Drive" and "Share with Me". This was corrected with the display change made on April 19.
Posted Apr 26, 2024 - 10:19 PDT
Identified
There is a new way to access Google Drive files in Schoology.
https://psd401.freshservice.com/support/solutions/articles/6000039912

However, there is an issue with the 'Shared With Me" files. When they get deleted, Google Drive logs you out. making you log back in and follow the solution article above again.

Schoology is aware of this, and they are working on a solution. They also mentioned that other districts are also experiencing this issue.
Posted Apr 10, 2024 - 16:18 PDT
This incident affected: Schoology.