A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2026 - 08:39 PDT
Identified
Classlink has notified us that they have identified the cause of the issue and are working on a fix.
Posted Jun 01, 2026 - 07:34 PDT
Investigating
We have been notified by Classlink that they are investigating the cause of a login outage affecting PSD services. The portal is the primary affected service, but any login that uses the portal will be affected as well.
Posted Jun 01, 2026 - 07:22 PDT
This incident affected: Core District Services (PSD Portal) and Classlink (ClassLink Mobile apps, ClassLink My Apps, ClassLink My Files, ClassLink Roster Server, ClassLink Active Directory Integration).