Security Patch for Core Routers
Completed
The scheduled maintenance has been completed.
Posted Aug 26, 2023 - 11:01 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 26, 2023 - 09:00 PDT
Scheduled
We will be patching the core routers on Saturday morning. Multiple brief outages are expected between 2:00 AM and 11:00 AM.
Posted Aug 25, 2023 - 14:21 PDT
This scheduled maintenance affected: Powerschool (PowerSchool Products Enrollment, PowerSchool Products PowerSchool SIS, PowerSchool Products PowerSchool Special Programs), School Networks, Phones and Other Systems (Artondale Elementary, Discovery Elementary, Evergreen Elementary, Harbor Heights Elementary, Minter Creek Elementary, Pioneer Elementary, Purdy Elementary, Vaughn Elementary, Voyager Elementary, Goodman Middle School, Harbor Ridge Middle School, Key Peninsula Middle School, Kopachuck Middle School, Henderson Bay High School, Gig Harbor High School, Peninsula High School, Educational Service Center Campus, Community Transition Program (CTP/SVA), ChildFind), and Core District Services (Core Network, K-20 Internet Connectivity, AWS VPN Connection).