Multiple internet outages Saturday morning and afternoon.
Completed
The scheduled maintenance has been completed.
Posted Dec 23, 2023 - 16:00 PST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 23, 2023 - 08:00 PST
Scheduled
We will be continuing reconfiguration operations on the firewall on Saturday. This could lead to multiple outages as new settings are applied and systems are rebooted.
Posted Dec 20, 2023 - 12:37 PST
This scheduled maintenance affected: Powerschool (PowerSchool Products Enrollment, PowerSchool Products PowerSchool SIS, PowerSchool Products PowerSchool Special Programs), School Networks, Phones and Other Systems (Artondale Elementary, Discovery Elementary, Evergreen Elementary, Harbor Heights Elementary, Minter Creek Elementary, Pioneer Elementary, Purdy Elementary, Vaughn Elementary, Voyager Elementary, Goodman Middle School, Harbor Ridge Middle School, Key Peninsula Middle School, Kopachuck Middle School, Henderson Bay High School, Gig Harbor High School, Peninsula High School, Educational Service Center Campus, Community Transition Program (CTP/SVA), ChildFind), and Core District Services (Core Network, K-20 Internet Connectivity, Firewall & VPN Connectivity, AWS VPN Connection).