Multiple Maintenance Operations over Thanksgiving Break
Completed
The scheduled maintenance has been completed.
Posted Nov 25, 2023 - 08:00 PST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 23, 2023 - 08:00 PST
Scheduled
Tech Services will be performing maintenance on multiple services over the Holiday. Notably, you should expect multiple brief network and internet outages on Thursday and Friday as network equipment is updated. This will affect all locations at different times as switches and access points are updated. All services should be back to normal by 8:00 PM on Friday.
Posted Nov 20, 2023 - 09:15 PST
This scheduled maintenance affected: School Networks, Phones and Other Systems (Artondale Elementary, Discovery Elementary, Evergreen Elementary, Harbor Heights Elementary, Minter Creek Elementary, Pioneer Elementary, Purdy Elementary, Vaughn Elementary, Voyager Elementary, Goodman Middle School, Harbor Ridge Middle School, Key Peninsula Middle School, Kopachuck Middle School, Henderson Bay High School, Gig Harbor High School, Peninsula High School, Educational Service Center Campus, Community Transition Program (CTP/SVA), ChildFind).