PowerSchool is up and running, if you are still experiencing issues please use the standard ticket process.
Posted Jun 04, 2026 - 07:49 PDT
Monitoring
PowerSchool is back up and running, we will continue to monitor for performance.
Posted Jun 04, 2026 - 07:17 PDT
Investigating
We have been made aware of an issue preventing users from logging into PowerSchool. We have opened a ticket with the vendor and will post updates here.
Posted Jun 04, 2026 - 06:37 PDT
This incident affected: Powerschool (PowerSchool Products PowerSchool SIS).