Issues with PowerSchool Attachments and System Logouts. Our Engineers are investigating.

Resolved

We have worked with the vendor and believe we have resolved the issues with Logouts and Document Attachments. If you continue to have issues with PowerSchool please submit a ticket with IT via Service Central.
Posted Dec 08, 2025 - 09:58 PST

Update

We are continuing to investigate this issue.
Posted Dec 05, 2025 - 11:05 PST

Update

We are continuing to investigate this issue.
Posted Dec 05, 2025 - 10:58 PST

Investigating

We are currently investigating this issue.
Posted Dec 05, 2025 - 10:53 PST
This incident affected: Powerschool (PowerSchool Products Enrollment, PowerSchool Products PowerSchool SIS, PowerSchool Products PowerSchool Special Programs).