Outside lines are unable to connect to PSD phone lines x1000 through x3499.
Resolved
This incident has been resolved.
Posted Sep 02, 2021 - 19:00 PDT
Identified
Comcast is experiencing an outage. Estimated time of repair is 6PM.
Posted Sep 02, 2021 - 15:53 PDT
This incident affected: School Networks, Phones and Other Systems (Artondale Elementary, Discovery Elementary, Evergreen Elementary, Harbor Heights Elementary, Goodman Middle School, Harbor Ridge Middle School, Gig Harbor High School, Educational Service Center Campus).