Internet outage Monday Evening
Completed
The scheduled maintenance has been completed.
Posted Apr 15, 2024 - 22:00 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 15, 2024 - 20:00 PDT
Scheduled
Our ISP will be rebooting our connection to apply licenses and configurations. The outage will be 15-30 minutes long somewhere within the 8-10 PM window.
Posted Apr 11, 2024 - 17:07 PDT
This scheduled maintenance affected: School Networks, Phones and Other Systems (Artondale Elementary, Discovery Elementary, Evergreen Elementary, Harbor Heights Elementary, Minter Creek Elementary, Pioneer Elementary, Purdy Elementary, Vaughn Elementary, Voyager Elementary, Goodman Middle School, Harbor Ridge Middle School, Key Peninsula Middle School, Kopachuck Middle School, Henderson Bay High School, Gig Harbor High School, Peninsula High School, Educational Service Center Campus, Community Transition Program (CTP/SVA), ChildFind).