Adobe Products down
Resolved
This incident has been resolved.
Posted Oct 30, 2023 - 14:17 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2023 - 12:21 PDT
Investigating
Adobe Creative Cloud services and applications are down for all students at PSD. We are working on the issue, and will update this status page when a solution is found.
Posted Oct 30, 2023 - 11:09 PDT
This incident affected: Other Third-Party Applications (Other Curriculum Software).