Classlink Portal is down for Maintenance
Resolved
This incident has been resolved.
Posted Aug 01, 2023 - 10:59 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 01, 2023 - 10:59 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 01, 2023 - 10:23 PDT
This incident affected: Core District Services (PSD Portal, Single Sign-On System).