Clever Apps experiencing issues
Resolved
This incident has been resolved.
Posted Apr 06, 2023 - 16:46 PDT
Monitoring
Clever's Engineering team has implemented a fix to the login issue and they are going to continue monitor the situation.

If you are still unable to log into your application or curriculum from the PSD Portal, please submit a Service Central ticket at https://psd401.freshservice.com/support/home
Posted Apr 06, 2023 - 12:08 PDT
Identified
Clever is experiencing issues. Apps (Amplify, i-Ready, Reading Wonders, Second Step, Springboard, etc...) that use Clever may have issues.
https://status.clever.com/
Posted Apr 06, 2023 - 10:03 PDT
This incident affected: Other Third-Party Applications (Clever Apps Dashboard).