Zoom Outage

Resolved

We are starting to see services from Zoom returning. Please contact the PSD helpdesk if you continue to have issues with either the zoom app or your desk phone.
Posted Apr 16, 2025 - 13:54 PDT

Investigating

Zoom is having a global outage at this time. This outage is affecting multiple systems/services. Desk phones are down, but calls through the app on desktop seem to still be working for now. Zoom is aware of the outage and is investigating.
Posted Apr 16, 2025 - 13:12 PDT
This incident affected: Zoom (Zoom Zoom Meetings).