Emergency router maintenance at PHS
Completed
The scheduled maintenance has been completed.
Posted Sep 28, 2023 - 06:01 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 28, 2023 - 04:00 PDT
Scheduled
We will be rebooting the PHS Router at 4:00 AM tomorrow morning. This will interrupt all traffic and phones in and out of PHS for approximately 15-30 minutes.
Posted Sep 27, 2023 - 17:55 PDT
This scheduled maintenance affected: School Networks, Phones and Other Systems (Peninsula High School).